Announcement

Collapse
No announcement yet.

System one filters

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • System one filters

    I just changed my oil filter from the Wix racing to the System one. It has the 45 micron size element. The wix I use does not have a relief and nor does the block. When I installed the System one I lost 10 psi @ idle. I did not want to waste 25 bucks to put a Wix back on to see if I gained pressure. The System one has a by-pass. I use Brad Penn 50w. Has anyone noticed this when using System one...Is it flow rate?.....Also the outside air temp was < 50, and water temp even colder. I use aluminum rods that require at least 145 oil temp.
    sigpic

  • #2
    Re: System one filters

    Originally posted by Canoejockey View Post
    I just changed my oil filter from the Wix racing to the System one. It has the 45 micron size element. The wix I use does not have a relief and nor does the block. When I installed the System one I lost 10 psi @ idle. I did not want to waste 25 bucks to put a Wix back on to see if I gained pressure. The System one has a by-pass. I use Brad Penn 50w. Has anyone noticed this when using System one...Is it flow rate?.....Also the outside air temp was < 50, and water temp even colder. I use aluminum rods that require at least 145 oil temp.
    I have had good luck with Wix-Racing...50w at low temp is hard to move.....
    come on out to the west-coast!...its allways warm..

    Comment

    Working...
    X